ComputeCpp:RT0100 with ComputeCpp 2.1.0 on VS2019

After upgrading to ComputeCpp 2.1.0 (from 1.2.0), I can’t get my code to work in any way anymore.

In most cases, I get an exception “ComputeCpp:RT0100 Binary format for key=‘0’, indent-’’ is not recognized”. Unfortunately, I don’t even know where to look for additional information.

The only way I can get past that error is by using COMPUTE_CPP_BITCODE=ptx64 and commenting out all mathematical functions that I need inside my kernels.

(I’m running on GeForce GTX 1050 Ti with Max-Q Design on platform NVIDIA CUDA)

The hardware you are using is a Nvidia GPU so you would need to compile with the ptx64 flag in order for your code to be executed on the GPU. This was the same in 1.2.0 too so are you sure you were trying to execute your code on the same GPU, or perhaps you were just executing on the host device (CPU?).
There are some mising built-ins for our ptx implementation so some mathematical functions may fail at the moment.
Can you double check that you were actually offloading to the same GPU?

Thanks for the clarification. May it be that ptx64 has become active by default since 1.3.0? That would explain my confusion.

In any case, on trying harder to get ptx64 running with 2.1.0 I found out that the only culprit was the function rsqrt which definitely worked back with 1.3.0. Luckily, that function is trivial to avoid. Changing the code to 1/sqrt it appears to run just fine.

I don’t think so but perhaps something has changed since then. Maybe before you were just running on the host device.

Glad you got it working.