Tensorflow build error

I am trying to build a tensorflow for armV8 following instruction TensorFlow ARM Setup
After executing command:

bazel --output_user_root=$TMPDIR build --config=sycl_arm -c opt --verbose_failures --copt=-Wno-c++11-narrowing

I got following error:

ERROR: no such package ‘@local_config_sycl//crosstool’: Traceback (most recent call last):
File “/harddisk1/liangzhao/Downloads/tensorflow/third_party/sycl/sycl_configure.bzl”, line 280
_tpl(repository_ctx, “sycl:BUILD”, _get_s…))
File “/harddisk1/liangzhao/Downloads/tensorflow/third_party/sycl/sycl_configure.bzl”, line 280, in _tpl
File “/harddisk1/liangzhao/Downloads/tensorflow/third_party/sycl/sycl_configure.bzl”, line 215, in _get_sycldnn_substitutions
File “/harddisk1/liangzhao/Downloads/tensorflow/third_party/sycl/sycl_configure.bzl”, line 101, in _find_computecpp_root
_check_computecpp_version(repository_ctx, computecpp_path)
File “/harddisk1/liangzhao/Downloads/tensorflow/third_party/sycl/sycl_configure.bzl”, line 89, in _check_computecpp_version
result.stdout.split(" ")[1]
index out of range (index is 1, but sequence has 1 elements)
INFO: Elapsed time: 0.122s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (0 packages loaded)

Did anybody encounter this issue before? Thanks a lot!

It’s possible this is an issue with how ComputeCpp has been put on your computer.

It may mean that the command
${COMPUTECPP_TOOLKIT_PATH}/bin/computecpp_info --dump-version failed where ${COMPUTECPP_TOOLKIT_PATH} is the path provided when running ./configure

This command from the instructions sets this up:
export COMPUTECPP_TOOLKIT_PATH=$HOME/ComputeCpp-CE-1.1.3-Ubuntu-14.04-ARM_32
Point this variable to where the bin/lib/include folders from the ComputeCpp release package file, then run ./configure again and ensure the correct path is being used.

Hi Rod,
Thanks for the response. I’ve done what you have suggested. but I still get the same error.
I’ve repeated the process starting from ln -s /usr/include/aarch64-linux-gnu/python2.7/ $HOME/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/aarch64-linux-gnu/libc/usr/include/aarch64-linux-gnu/

And it seems that configuration was done properly.
WARNING: --batch mode is deprecated. Please instead explicitly shut down your Bazel server using the command “bazel shutdown”.
You have bazel 0.16.0 installed.
Preconfigured Bazel build configs. You can use any of the below by adding “-- config=<>” to your build command. See tools/bazel.rc for more details.
–config=mkl # Build with MKL support.
–config=acl # Build with ACL support.
–config=monolithic # Config for mostly static monolithic build.
Configuration finished

Following is the files path:

| - …
| - liangzhao/
| - ComputeCpp-CE-1.1.3-Ubuntu-16.04-ARM_64/
| - Downloads/
| |
| | - tensorflow
| | - …
| - gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/
| - …

Ok thanks. It’s not clear to us what is causing the issue.
Can you try adding a debug print with fail(computecpp_info_cmd) after this line, and see what the output is?
Then can you check if you are able to run the command printed, and send us the output from that command?